帮酷LOGO
  • 显示原文与译文双语对照的内容


问题:

I Ubuntu 12.04 USB USB USB USB USB USB USB Wireless Wireless Wireless Wireless Wireless assistance assistance assistance 。 这个装置不能在盒子里工作。 尝试进入NDISWrapper路由,但使用了 GUI,收到以下消息:

Module could not be loaded. Error was:
FATAL: Module ndiswrapper not found.
Is the ndiswrapper module installed?

尽管它显示在GUI中,但设备仍然不能正常工作。

我该如何从这里开始?


回答 1:

现在,看起来一个解决方案是从源代码构建和安装 ndiswrapper 。 我向你介绍 。Brian"让 Belkin N600 DB在Ubuntu上工作"指南:

卸载内置ndiswrapper并清理你以前拥有的任何配置:

sudo apt-get remove --purge ndiswrapper-common ndiswrapper-utils-1.9 ndisgtk
sudo rm/lib/modules/$(uname -r)/kernel/ubuntu/ndiswrapper/ndiswrapper.ko
sudo rm/etc/modprobe.d/ndiswrapper.conf
sudo rm -r/etc/ndiswrapper/*

接下来,从源代码生成 ndiswrapper:

sudo apt-get install linux-headers-$(uname -r) build-essential
wget http://downloads.sourceforge.net/project/ndiswrapper/stable/ndiswrapper-1.57.tar.gz
tar -xvf ndiswrapper-1.57.tar.gz
cd ndiswrapper-1.57
make
sudo make install
sudo depmod -a
sudo update-initramfs -u

这也适用于 ndiswrapper-1.58

注意:上摘录使我无法使用自己的WiFi,但我仍无法完成整个指南,因为我的WiFi可能是由于路由器配置而导致的。 您的情况可能会有所不同。


回答 2:

Belkin F9L1101基于 Realtek RTL8192芯片组,它有linux驱动程序。 因此,你可以通过下载RTL8192驱动程序源代码并编译。

sudo apt-get install build-essential linux-headers-generic git
git clone https://github.com/lwfinger/rtl8192du.git
cd rtl8192du
make
sudo make install
modprobe 8192du

这对我来说很完美。 我现在连接到 AskUbuntu,在 Ubuntu 14.04 64位 上有一个F9L1101适配器。 如果你的版本超过 14.04,那么我无法在任何版本的版本上进行测试,所以我不能保证它能正常工作,如果在早期版本的Ubuntu上失败,那么你可以选择升级到 14.04.

如果你不能插入互联网连接,你需要下载这个,只需克隆一台拥有互联网的计算机,然后使用驱动器将驱动程序复制到你的电脑。 然后按照计算机上的剩余步骤进行操作。





Copyright © 2011 HelpLib All rights reserved.    知识分享协议 京ICP备05059198号-3  |  如果智培  |  酷兔英语