帮酷LOGO
0 0 评论
  • 显示原文与译文双语对照的内容
文章标签:JAVA  Firefox  MAKE  版本  Openjdk  

问题:

我的( openjdk-6-jre 6 b27-1.12.6-1ubuntu 0.12.04.2 ) 6和 7 JRE ( openjdk-7-jre 7 u25-2.3.10-1ubuntu 0.12.04.2 ) 并行安装。我不知道为什么两者都有,我不知道怎么安装它们。

但是,Firefox Java插件偶尔被报告过某些网站过时,似乎它依赖于 JRE 6. 如何让 Firefox 使用新版本? 删除 JRE 6似乎是个坏主意;当我尝试这样做时,我觉得很多软件仍然依赖旧的JRE,因为删除它会删除像 jedit 这样的程序。

我是不是 mix? 我甚至不确定FF插件是如何干扰jre的。

编辑:

在尝试了更多的情况下,问题仍然存在。 使用 update-alternatives --config java,我看到默认的Java版本( 带状态"手动模式") 已经设置为 Java 7,java -version 返回" 1.7.0 _25"。 无法分析文件"%s"。可能文件不存在,或者不是有效的信息页。 /usr/lib/jvm/java-7-openjdk-i386/jre/lib/i386/IcedTeaPlugin.so 存在,但 Firefox 在查看 about:plugins 时显示了 Java 6插件。

::的:

如何让 Firefox 使用属于默认Java版本的IcedTea插件?


回答 1:

从软件中心或者使用 命令行 安装 icedtea 插件的版本 7的

按Ctrl+Alt+T键打开终端,然后输入:


sudo apt-get install icedtea-7-plugin



删除较旧的的费用:


sudo apt-get remove icedtea-6-plugin



然后重新启动 Firefox 并键入 about:plugins 以检查java插件的版本。 如果要检查版本是否正确,请访问 java网站

希望这个有帮助


回答 2:

大多数网站使用javascript检查浏览器运行的版本,因为它不支持在你的系统中更新 Java Java版本。 如果JavaApplet正常工作的话,我将忽略这些消息中的任何一个。

要检查运行的Java Firefox 版本只是在位置栏( 地址栏) about:plugins 上,它应该显示所有的插件 Firefox 正在使用。

我打赌 Firefox 使用最新的JRE,网站只是抱怨它不是与Oracle的版本相同的版本。 保持你的系统更新并忽略。


回答 3:

如果你使用的是 ,你需要安装


sudo yum install icedtea-web



在这里之后重新启动浏览器。


回答 4:

你可能需要安装相关的插件软件包,以便与你的java版本一起使用:


sudo apt-get install icedtea-7-plugin



这里插件适用于主要浏览器: Firefox,Chromium,Google Chrome 和 Epiphany。 你需要重新启动浏览器才能使插件更改生效。

更多信息:

http://apt.ubuntu.com/p/icedtea-7-plugin

https://help.ubuntu.com/community/Java




文章标签:JAVA  MAKE  版本  Firefox  Openjdk  

Copyright © 2011 HelpLib All rights reserved.    知识分享协议 京ICP备05059198号-3  |  如果智培  |  酷兔英语