帮酷LOGO
0 0 评论
  • 显示原文与译文双语对照的内容
文章标签:UEFI  Windows 8  Windows  Window  wubi  SUP  

问题:

根据这个新闻,安全引导有一个官方的修复。 Ubuntu会适应它?

如果是的话,需要多长时间? 它是否允许从Wubi引导新计算机?


回答 1:

没有

Ubuntu已经支持安全引导,就像在新闻的真实源中提到的:

这意味着Linux发行版现在可以支持安全引导? 实际上他们已经能有一段时间了。 Ubuntu去年10月提供了安全启动支持,Fedora在January发布了安全启动支持。 使用的是 shim,而不是Linux基础装载器,也是由各种较小的分布使用的垫片。 LF加载器是同一问题的不同解决方案。

Wubi在 UEFI 系统上不工作,因为它使用不支持 GPT ( GUID分区表) 磁盘的grub4dos。 这与安全引导无关,而不是安全引导需要 UEFI。 这是第一个问题

安全引导将是第二个要解决的问题,因为所提供的解决方案必须签名为有用的( 我想既然我对这方面没有任何专业知识)。

第三个问题是有人应该处理它- 除非它是最高机密- 没有我看到的任何信息。 Bug 报告没有从 Wishlist 中看到任何变化,并保持 Unassigned: https://bugs.launchpad.net/wubi/+bug/694242


回答 2:

我知道ubuntu支持安全引导,但这是官方修复。

没有。Linux基金会已经发布了以程序的形式发布的 fix。 Ubuntu 12.10和Fedora都使用 ,以 shim 程序的形式来修复。 Fedora 18使用了较新和更强大的shim版本。除了某些组织可能支持一个解决方案或者其他解决方案之外,任何解决方案都没有更多的声明成为"官方"的解决方案。 从这个意义上说,shim 是"更正式"的,因为Ubuntu是包含在Ubuntu里的。 shim的作者Matthew写了这篇博文,比较并对比了这两种程序。 他说他正在努力将PreBootloader方法集成到 shim 中,有效地将两个程序组合。

除了bcbc已经确定的GPT问题之外,is还有一个更基本的问题是它不支持电子表格引导。 为了使用基于电喷的Windows 安装,需要支持电喷模式引导装载器。 修补grub4dos以支持GPT将对这里任务不足。 如果你不需要使用EFI引导加载程序,你也需要使用EFI引导加载程序,因此它的名称为 /*Pre *Bootloader.




文章标签:Window  Windows  SUP  Windows 8  UEFI  wubi  

Copyright © 2011 HelpLib All rights reserved.    知识分享协议 京ICP备05059198号-3  |  如果智培  |  酷兔英语