帮酷LOGO
0 0 评论
  • 显示原文与译文双语对照的内容
文章标签:Openjdk  

问题:

在发布 apt-cache search jdk 之后,我看到了 openjdk-8-jdkopenjdk-9-jdk。 我不确定应该安装哪一个。

我从 oracle below 网站查看了SDK下载,并且我无法立即找到 SDK 9. 为什么会发生这种情况?

http://www.oracle.com/technetwork/java/javase/downloads/jdk8-downloads-2133151.html


回答 1:

在安装NetBeans时,如果要安装 openjdk-8-jdk,因为openjdk-9-jdk与默认的Ubuntu库不兼容,至少它在 Ubuntu 16.04中并不兼容 NetBeans。

另一种方法是安装openjdk-8-jdk和 openjdk-9-jdk,并使用 update-alternatives ( 在Ubuntu中默认安装) 或者 update-java-alternatives ( 安装openjdk-8-jdk时安装的) 在运行应用程序之前手动选择要使用哪个 Java。 请参见 update-java-alternatives vs 更新可选的--config


回答 2:

Java 9仍在开发中。 你可以在 http://jdk.java.net/9/ 找到官方下载。 你应该下载哪个版本完全是你对它的计划的一个问题。

编辑:它已经在 2017月正式发布。




文章标签:Openjdk  

Copyright © 2011 HelpLib All rights reserved.    知识分享协议 京ICP备05059198号-3  |  如果智培  |  酷兔英语