帮酷LOGO
0 0 评论
  • 显示原文与译文双语对照的内容
文章标签:内核  Ubuntu  版本  

问题:

我使用 14.04.2可能它已经超过 14.04.1,但我的内核版本似乎仍然 3.13.

根据 14.04.2看来,3.16. 我不明白为什么没有自动升级。


回答 1:

内核不会通过常规更新自动升级到下一个主要版本( 3.13至 3.16 )。 你可以通过运行


sudo apt-get install linux-generic-lts-utopic



你可以阅读关于 HWE堆栈的信息。

如果你想从 Ubuntu 14.04.2安装图形堆栈,那么你可以运行


sudo apt-get install --install-recommends linux-generic-lts-utopic xserver-xorg-lts-utopic libqt5gui5 libgles1-mesa-lts-utopic libgles2-mesa-lts-utopic libgl1-mesa-glx-lts-utopic libgl1-mesa-glx-lts-utopic:i386 libglapi-mesa-lts-utopic:i386 libegl1-mesa-drivers-lts-utopic



这里的是一个很好的指南。

Ubuntu命令可以删除许多有用的软件包。 在某些情况下,它删除了ubuntu桌面。 所以运行它是不合适的。 无论如何,仔细看,看看哪些包将被删除之前,同意继续。

对新内核满意后,可以删除 3.13个内核元数据包,以防止 3.13内核更新。 它可以由


sudo apt-get remove linux-image-generic linux-headers-generic



也可以使用Synaptic删除旧的内核图像和头部。

更新 3.19内核可以用于 Ubuntu 14.04. 它可以通过


sudo apt-get install linux-generic-lts-vivid




回答 2:

短回答

如果你想移到新的通用内核( 调用的启用堆栈。) 系列,你可以运行以下命令


sudo apt-get install --install-recommends linux-generic-lts-utopic xserver-xorg-lts-utopic libgl1-mesa-glx-lts-utopic libegl1-mesa-drivers-lts-utopic



注意:安装上述命令中提到的所有包很重要,否则可能会破坏系统。

长答案

Ubuntu使用它自己的一系列修改内核,称为通用内核。 它们基于linux团队的原始版本,你可以在 https://www.kernel.org/ 看到它们。

但是当你安装一个特定版本的Ubuntu时,它带有一些通用的内核( 说 3.13. x 系列),并且它坚持它。 因此,每当使用命令更新系统时


sudo apt-get update && sudo apt-get upgrade



你将自动更新内核,但你将坚持相同的系列( 3。13.x )

如果你希望移动到新的通用内核系列,你必须像前面提到的那样做。

或者,你可能希望从 https://www.kernel.org/ 安装最新的内核( 带或者不改变当前的)。 在内核新手,提供了说明。




文章标签:版本  Ubuntu  内核  

Copyright © 2011 HelpLib All rights reserved.    知识分享协议 京ICP备05059198号-3  |  如果智培  |  酷兔英语