帮酷LOGO
0 0 评论
  • 显示原文与译文双语对照的内容
文章标签:Drive  INT  DEP  installing  EPS  print  lsb  中断  

问题:

我正在安装 Epson XP-310 驱动程序,从这个网站。

尝试安装下载的.deb 文件时,出现以下错误:


The Package System is broken 



epson-inkjet-printer-201303w:i386: Depends: lsb(>=3.2) but 4.1+Debian11ubuntu is installed



我很困惑。它说我必须有> 版本 =3。2 但我有 4.1. 我为什么要获得依赖项错误?


回答 1:

我的Epson WF-3520 和Epson网站上的司机也有同样的问题。 这解决了我的问题:

尝试,以确保损坏的驱动程序将被删除:

sudo apt-get -f install

然后从软件包管理器中安装驱动程序


sudo apt-get install printer-driver-escpr



我在软件包管理器中安装了"printer-driver-escpr"版本 1.3.0 -1,驱动程序在 Epson WF-3520中为我工作。

现在,尝试安装epson打印机。


回答 2:

当我在 Ubuntu 16.04中安装我的Epson打印机时遇到了一个很糟糕的问题:我在Ubuntu软件中心遇到了消息依赖性,而gdebi的消息却同样。 我现在将指出,gnome软件中心除了少量以前使用的软件包没有显示缺失的依赖项。 除了告诉我在安装 alien的最后,安装的依赖性不是很大,它们不是很大的用途:


sudo apt-get install alien 



然后我去了网站,输入了我的打印机,然后点击了搜索列表,然后点击了或者 rpm s 我下载了的rpm

转到下载文件夹并在终端中打开并运行:


sudo alien -i your_epson_printer_package_file.rpm



然后关掉我的打印机,转到设置并删除它。

重新启动立即识别的打印机。 然后打印了一个测试页面


回答 3:

就是这个问题。 '固定'只是下载驱动程序的正确版本这个站点上提供了 32个和 64位版本: http://download.ebz.epson.net/dsc/search/01/search/

我下载了 32位( 因为我没有读过文件名,只是看到了 .deb 并下载了),但实际上需要 64位版本- 也许OP执行了同样的操作?

此外,如果你想让它正常工作,它还需要一点耐心,但是如果你坚持这样做,它会工作在最后:。


回答 4:

try sudo apt-get -f install


sudo apt-get update



sudo dpkg --configure -a 



然后清除缓存

 
sudo apt-get clean



 

回答 5:

使用 synaptic,我安装了增量 lsb。lsb释放。lsb打印。lsb-cxx。lsb图形。lsb桌面和 lsb-core ( 其中一些是预先安装的)。 霰弹枪每次都失败了。 在我安装lsb-pkgchk3之前。 我是lovin我的爱普生 WF-3520 在 fully-up-to-date 12.04.


回答 6:

我也有同样的问题,因为我厌倦了不打印。

首先安装外星人。 这是将rpm转换为deb文件的包转换工具,反之亦然。


$ sudo apt-get install alien 



使用外星人将文件转换为 RPM:


$ sudo alien --to-rpm/path/to/epson-inkjet-printer-201303w_1.0.0-1lsb3.2_amd64.deb --scripts


epson-inkjet-printer-201303w-1.0.0-2.x86_64.rpm generated



使用 --scripts 参数来包含脚本。 然后把你刚才转换的那个. rpm 文件转换为。deb


$ sudo alien --to-deb/path/to/epson-inkjet-printer-201303w-1.0.0-2.x86_64.rpm --scripts


epson-inkjet-printer-201303w_1.0.0-3_amd64.deb generated



我想你可以把这个文件作为一个 rpm。


$ sudo alien -i package_file.rpm



-i 将直接运行rpm文件的地方。

之后我就能成功安装软件包了。


回答 7:

在我的例子中,驱动程序的安装 epson-inkjet-printer-stylus-office-tx510fn-series 产生同样的错误。在我的例子中注意到:


debconf: DbDriver"config":/var/cache/debconf/config.dat is locked by 


another process: Die Ressource ist zur Zeit nicht verfügbar



因此我找到了这个主题,这个主题是关于锁定的.dat 文件的。 使用命令

sudo rm/var/cache/debconf/*.dat

我可以解决这个问题。


回答 8:

我有一个类似的问题,我已经下载并安装了 14.04的lsb核心包,它可以。

尝试这个:


sudo add-apt-repository"deb http://cz.archive.ubuntu.com/ubuntu trusty main" && sudo apt-get update && sudo apt-get install lsb-core


-y



然后,尝试再次安装 epson-inkjet-printer-201303w。




文章标签:INT  Drive  DEP  print  dependency  installing  printer  中断  

Copyright © 2011 HelpLib All rights reserved.    知识分享协议 京ICP备05059198号-3  |  如果智培  |  酷兔英语